git

install specific or latest version of git

030

030

7,261 downloads

4,690 latest version

4.8 quality score

Version information

  • 0.2.6 (latest)
  • 0.2.5
  • 0.2.4
  • 0.2.3
  • 0.2.2
  • 0.2.0
  • 0.1.0
released Oct 18th 2016
This version is compatible with:
  • Puppet Enterprise 2021.0.x, 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 4.0.0
  • RedHat
    ,
    CentOS

Start using this module

Documentation

030/git — version 0.2.6 Oct 18th 2016

Build Status Puppet Forge Puppet Forge Downloads

puppet-git

This module installs the latest git version

installation

specific

In order to install a specific version, e.g. 2.5.2 include the class

include git

in the manifest, or in hiera:

classes:
  - git

and specify

git::version: 2.5.2

in hiera

latest

In order to install the latest version of git just include the git class

include git