get_swifty

pdk
tasks
Simple proof of concept of a Puppet Task written in Swift.

Abir Majumdar

beersy

4,835 downloads

4,521 latest version

5.0 quality score

Version information

  • 0.1.2 (latest)
  • 0.1.1
  • 0.1.0
released Mar 29th 2018
This version is compatible with:
  • Puppet Enterprise 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 4.7.0 < 6.0.0
  • Darwin
    ,
    Ubuntu
Tasks:
  • get_swifty

Start using this module

Documentation

beersy/get_swifty — version 0.1.2 Mar 29th 2018

get_swifty

Simple proof of concept of a Puppet Task written in Swift. The task should run natively on any Mac OS version with Swift 2 or higher. It has also been tested on Ubuntu 16.04. For instructions on how to install Swift on Ubuntu read Swift's Getting Started documentation.

screenshot