pf

Puppet Module for managing PF

Matt Dainty

bodgit

4,100 downloads

4,100 latest version

5.0 quality score

Version information

  • 1.0.0 (latest)
released Jun 20th 2018
This version is compatible with:
  • Puppet Enterprise 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >=4.5.0 <6.0.0
  • OpenBSD

Start using this module

Tags: pf, authpf

Documentation

bodgit/pf — version 1.0.0 Jun 20th 2018

pf

Tested with Travis CI

Build Status Coverage Status Puppet Forge

Table of Contents

  1. Description
  2. Setup - The basics of getting started with pf
  3. Usage - Configuration options and additional functionality
  4. Reference - An under-the-hood peek at what the module is doing and how
  5. Limitations - OS compatibility, etc.
  6. Development - Guide for contributing to the module

Description

This module manages the packet filter (pf) firewall primarily found on OpenBSD. It manages the /etc/pf.conf configuration file containing the firewall rules. It can also manage the user shell (authpf) used for implementing an authenticating gateway.

OpenBSD is supported using Puppet 4.5.0 or later.

Setup

Beginning with pf

To use the default example ruleset:

class { '::pf':
  source => '/etc/examples/pf.conf',
}

Usage

To set up the authenticating gateway:

include ::bsdauth
include ::bsdauth::authpf

class { '::pf':
  content => @(EOS/L),
    int_if="em0"
    ...
    ťable <authpf_users> persist
    ...
    anchor "authpf/*" in on $int_if
    ...
    | EOS
}

class { '::pf::authpf':
  rules => @(EOS/L),
    int_if="em0"
    ...
    pass in on $int_if inet from <authpf_users> to ! $int_if:network \
      keep state
    ...
    | EOS
}

group { 'alice':
  ensure => present,
}

user { 'alice':
  ensure     => present,
  gid        => 'alice',
  loginclass => 'authpf',
  managehome => true,
}

Reference

The reference documentation is generated with puppet-strings and the latest version of the documentation is hosted at https://bodgit.github.io/puppet-pf/.

Limitations

This module has been built on and tested against Puppet 4.5.0 and higher.

The module has been tested on:

  • OpenBSD 6.2/6.3

Development

The module has both rspec-puppet and beaker-rspec tests. Run them with:

$ bundle exec rake test
$ PUPPET_INSTALL_TYPE=agent PUPPET_INSTALL_VERSION=x.y.z bundle exec rake beaker:<nodeset>

Please log issues or pull requests at github.