pypolicydspf

A module to configure python-postfix-policyd-spf

Cirrax GmbH

cirrax

4,704 downloads

4,704 latest version

5.0 quality score

Version information

  • 1.0.0 (latest)
released Mar 11th 2018
This version is compatible with:
  • Puppet Enterprise 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >=4.0.0 < 6.0.0
  • Debian
    , Ubuntu

Start using this module

Documentation

cirrax/pypolicydspf — version 1.0.0 Mar 11th 2018

puppet module for pypolicyd_spf

Build Status Puppet Forge Puppet Forge Puppet Forge Puppet Forge

Table of Contents

  1. Overview
  2. Usage
  3. Reference
  4. Contribuiting

Overview

This module is used to configure python-postfix-policyd-spf.

Usage

To start using pypolicydspf you need to include the pypolicydspf main class and tell your're postfix to use it.

A minimal example might be:

class{'pypolicydspf'}

If you like to use hiera, you can define:

---
pypolicydspf::config:
  PermError_reject: 'True'

Reference

All classes are documented in the manifests

Contributing

Please report bugs and feature request using GitHub issue tracker.

For pull requests, it is very much appreciated to check your Puppet manifest with puppet-lint and the available spec tests in order to follow the recommended Puppet style guidelines from the Puppet Labs style guide.

Authors

This module is mainly written by Cirrax GmbH.

See the list of contributors for a list of all contributors.