java

Install Java JRE and JDK 1.7 along with Maven and Gradle 2.3

David Hopson

darkmantle

8,183 downloads

8,086 latest version

3.9 quality score

Version information

  • 1.0.2 (latest)
  • 1.0.1
released Apr 27th 2015
This version is compatible with:
  • Ubuntu

Start using this module

Tags: java, openjdk

Documentation

darkmantle/java — version 1.0.2 Apr 27th 2015

Darkmantle Puppet: Java

This is the Java module in my series of WebDev Puppet Configurations

Dependencies

apt by puppetlabs

Installation

Make sure you install the dependencies above!

Puppet

puppet module install darkmantle-java

Git Submodule

git submodule add https://github.com/darkmantle/puppet-java.git modules/java

Usage

Create a manifest that has the following code:

Exec {
  path => ["/usr/bin", "/bin", "/usr/sbin", "/sbin", "/usr/local/bin", "/usr/local/sbin"]
}

# basic install (version 7)
include java

# optional: if you want a lower or higher version (5,6 or 8 for example) and you know its available in the repository
# under the default name of openjdk-*-jdk then you can use this method
class { 'java:' $version => '8' }