Forge Home

wls_install

partner
pdk
Oracle WebLogic (10, 11, 12 and 14)module for Linux, Solaris & AIX

Enterprise Modules

enterprisemodules

29,019 downloads

333 latest version

5.0 quality score

Version information

  • 3.10.1 (latest)
  • 3.10.0
  • 3.9.0
  • 3.8.0
  • 3.7.5
  • 3.7.4
  • 3.7.3
  • 3.7.2
  • 3.7.1
  • 3.7.0
  • 3.6.2
  • 3.6.1
  • 3.6.0
  • 3.5.0
  • 3.4.2
  • 3.4.1
  • 3.4.0
  • 3.3.2
  • 3.3.1
  • 3.3.0
  • 3.2.2
  • 3.2.1
  • 3.2.0
  • 3.1.4
  • 3.1.3
  • 3.1.2
  • 3.1.1
  • 3.1.0
  • 3.0.6
  • 3.0.5
  • 3.0.4
  • 3.0.3
  • 3.0.2
  • 3.0.1
  • 3.0.0
  • 2.1.12
released Oct 12th 2021
This version is compatible with:
  • Puppet Enterprise 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x, 2017.2.x, 2016.4.x
  • Puppet >=4.10.8 < 8.0.0
  • AIX
    ,
    RedHat
    ,
    CentOS
    ,
    OracleLinux
    ,
    Debian
    ,
    Solaris

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'enterprisemodules-wls_install', '3.10.1'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add enterprisemodules-wls_install
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install enterprisemodules-wls_install --version 3.10.1

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

enterprisemodules/wls_install — version 3.10.1 Oct 12th 2021

Enterprise Modules

Table of Contents

  1. Overview
  2. License
  3. Description - What the module does and why it is useful
  4. Setup
  1. Usage - Configuration options and additional functionality
  2. Reference - An under-the-hood peek at what the module is doing and how
  3. Limitations - OS compatibility, etc.

Overview

This module allows you to install an Oracle WebLogic or Fusion middleware stack. It is part of our family of Puppet modules to install, manage and secure Oracle WebLogic and Fusion Middleware with Puppet. Besides the wls_install module, this family also contains:

  • wls_config For configuring an Oracle WebLogic and other Fusion products

License

This is a commercially licensed module. But you can use the module on VirtualBox based development systems for FREE. You can request a FREE trial license here

FREE TRIAL

Check the License for details.

Description

This Puppet module allows you to install Oracle WebLogic and other products in the Oracle Fusion Middleware family.

Fusion Middleware Features

  • installs FMW software(add-on) to a middleware home, like OSB,SOA Suite, Oracle Identity & Access Management, Oracle Unified Directory, WebCenter Portal + Content
  • WebTier Oracle HTTP server
  • OSB, SOA Suite with BPM and BAM Cluster configuration support ( convert single osb/soa/bam servers to clusters and migrate OPSS to the database )
  • ADF/JRF support, Assign JRF libraries to a Server or Cluster target
  • IDM/OAM configurations with Oracle OHS OAM WebGate, Also Cluster support for OIM OAM
  • OUD Oracle Unified Directory install, WebLogic domain, instances creation & OUD control
  • Forms/Reports Oracle Forms & Reports
  • Change FMW log location of a managed server
  • Resource Adapterplan and entries for AQ, DB File and JMS

This module supports the installation of WebLogic versions:

  • 10g
  • 11g
  • 12c( 12.1.1 & 12.1.2 & 12.1.3, 12.2.1.3 12.2.1.4 + FMW infra )
  • 14c

Basic Domain Management

We support the creation of a domain. You can create different types of domains:

  • default WebLogic
  • JRF + EM + Coherence + OWSM + JAX-WS Advanced + Soap over JMS
  • OSB + JRF + EM + OWSM + ESS
  • OSB + SOA Suite + BAM + JRF + EM + OWSM + ESS
  • OSB + SOA Suite + BAM + BPM + JRF + EM + OWSM + ESS
  • SOA Suite + BAM + JRF + EM + OWSM + ESS
  • SOA Suite + BAM + BPM + JRF + EM + OWSM + ESS
  • WC (webcenter) + WCC ( Content ) + BPM + JRF + EM + OWSM
  • WC (webcenter) + JRF + EM + OWSM
  • OIM (Oracle Identity Manager) + OAM ( Oracle Access Manager)
  • OUD (Oracle Unified Directory)

The modules also allow you to pack a domain and copy it to another node in a cluster.

Security

The module has support for Java Secure Socket Extension support(JSSE) and Custom Identity and Trust Store support]

Startup and shutdown

  • Startup a nodemanager
  • Start or stop AdminServer, Managed or a Cluster
  • Storing WebLogic Credentials and using in WLST

Miscellaneous

  • Linux low on entropy or urandom fix
  • Dynamic targetting] by using the notes field in WebLogic for resource targetting

Check here to see the full documentation for this module.

Setup

Requirements

The wls_install module requires:

  • Puppet module enterprisemodules-easy_type installed.
  • Puppet version 4.10.8 or higher. Can be Puppet Enterprise or Puppet Open Source
  • WebLogic 10g or higher
  • A valid Oracle Weblogic or Fusion license
  • A valid Enterprise Modules license for usage.
  • Runs on most Linux systems.
  • Runs on Solaris
  • Windows systems are NOT supported

We support WebLogic versions:

  • WebLogic 10g
  • WebLogic 11g
  • WebLogic 12.1.2
  • WebLogic 12.1.3
  • WebLogic 12.2.1
  • WebLogic 12.2.1.1
  • WebLogic 12.2.1.2
  • WebLogic 12.2.1.3
  • WebLogic 12.2.1.4
  • WebLogic 14

And Fusion versions:

  • WebLogic 10g
  • WebLogic 11g
  • WebLogic 12c ( 12.1.1, 12.1.2, 12.1.3, 12.2.1, 12.2.1.1, 12.2.1.2, 12.2.1.3, 12.2.1.4)

Installing the wls_install module

To install these modules, you can use a Puppetfile

mod 'enterprisemodules/wls_install'               ,'3.0.x'

Then use the librarian-puppet or r10K to install the software.

You can also install the software using the puppet module command:

puppet module install enterprisemodules-wls_install

Usage

Building a total WebLogic or Fusion setup requires quite some work. To help you, we have built some examples. The repo contains a demonstration of a simple WebLogic installation.

Reference

Here you can find some more information regarding this puppet module:

Here are a related blog posts:

Some example code:

Limitations

This module runs on Solaris and most Linux versions. It requires a puppet version higher than 4.10.8. The module does NOT run on windows systems.