Forge Home

augeasproviders_core

approved
pdk
Alternative Augeas-based providers for Puppet

7,147,145 downloads

20,949 latest version

5.0 quality score

Version information

  • 3.1.0 (latest)
  • 3.0.0
  • 2.7.0
  • 2.6.0
  • 2.5.0
  • 2.4.0
  • 2.3.0
  • 2.2.0
  • 2.1.5
  • 2.1.4
  • 2.1.3
  • 2.1.2
  • 2.1.1
  • 2.1.0
  • 2.0.1
  • 2.0.0
released Aug 26th 2021
This version is compatible with:
  • Puppet Enterprise 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x
  • Puppet >= 6.0.0 < 8.0.0
  • Debian
    ,
    Ubuntu
    ,
    RedHat
    ,
    CentOS

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'herculesteam-augeasproviders_core', '3.1.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add herculesteam-augeasproviders_core
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install herculesteam-augeasproviders_core --version 3.1.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

herculesteam/augeasproviders_core — version 3.1.0 Aug 26th 2021

Puppet Forge Version Puppet Forge Downloads Puppet Forge Endorsement Build Status Coverage Status Sponsor

augeasproviders_core: library for building alternative Augeas-based providers for Puppet

Module description

This module provides a library for module authors to create new types and providers around config files, using the Augeas configuration library to read and modify them.

The advantage of using Augeas over the default Puppet parsedfile implementations is that Augeas will go to great lengths to preserve file formatting and comments, while also failing safely when needed.

If you're a user, you want to see the main augeasproviders project at augeasproviders.com.

Requirements

Ensure both Augeas and ruby-augeas 0.3.0+ bindings are installed and working as normal.

See Puppet/Augeas pre-requisites.

Development documentation

See docs/ (run make) or augeasproviders.com.

Issues

Please file any issues or suggestions on GitHub.