git_subtree

Install the git-subtree script for versions of git < 1.7.11
Joshua Hoblitt

Joshua Hoblitt

jhoblitt

10,433 downloads

10,433 latest version

3.9 quality score

Version information

  • 1.0.0 (latest)
released Jul 3rd 2019

Start using this module

Documentation

jhoblitt/git_subtree — version 1.0.0 Jul 3rd 2019

Puppet git_subtree Module

Description

Install the git-subtree script for versions of git < 1.7.11. Later versions of git include this functionality. Since subtree support is implemented as a shell script, it's trivial to install a copy of this script from recent releases on older git installations. This is known to work with at least git >= 1.7.

At the time of this writing, EPEL/6 is shipping git 1.7.1 and EPEL/5 is shipping git 1.7.4.1 .

Examples

include git_subtree

class{ 'git_subtree': }

Support

Please log tickets and issues at github

Copyright

Copyright (C) 2012-2013 Joshua Hoblitt jhoblitt@cpan.org