Forge Home

ir_agent

Module for installing and managing Rapid7 Insight Agent (ir_agent).

424 downloads

424 latest version

5.0 quality score

Version information

  • 1.0.0 (latest)
released Nov 2nd 2021
This version is compatible with:
  • Puppet Enterprise 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x
  • Puppet >= 6.19.1 < 8.0.0
  • , , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'nvergottini-ir_agent', '1.0.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add nvergottini-ir_agent
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install nvergottini-ir_agent --version 1.0.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

nvergottini/ir_agent — version 1.0.0 Nov 2nd 2021

ir_agent

This module is provided for deploying and configuring Rapid7 Insight Agent on Red Hat Enterprise Linux (and clones).

Table of Contents

  1. Description
  2. Setup
  3. Usage
  4. Limitations

Description

This module can be used to install, configure, and remove Rapid7 Insight Agent. Configurable options include proxy settings and enabling and disabling auditd compatibility mode.

Setup

Setup Requirements

This module requires (but does not include) the agent installer script from Rapid7. You will also need an installation token from Rapid7 to download the required certificates during installation.

Beginning with ir_agent

A basic usage of the class.

class { '::ir_agent':
  source => 'puppet:///modules/test/agent_installer_x64.sh',
  token  => 'us:01234567-89ab-cdef-0123-4567890abcde',
}

Usage

In most cases the basic usage is sufficient. For other cases, using a proxy and enabling auditd compatibility mode might be necessary.

class { '::ir_agent':
  source                    => 'puppet:///modules/test/agent_installer_x64.sh',
  token                     => 'us:01234567-89ab-cdef-0123-4567890abcde',
  auditd_compatibility_mode => true,
  https_proxy               => 'proxy.example.org:3128',
}

Limitations

If this module is used to install the Insight agent, it will install the audit package because it is a requirement for the Insight agent. If this module is later used to remove the Insight agent, it will not remove the audit package and it will enable and start the auditd service (if it was stopped and disabled). The audit package can then be removed and this module will not reinstall the audit package as long as ensure => absent.