gpasswd

Adds support for :manages_members to the Linux group native type

Onyx Point

onyxpoint

234,128 downloads

201,624 latest version

5.0 quality score

Version information

  • 1.1.1 (latest)
  • 1.1.0
  • 1.0.7
  • 1.0.6
  • 1.0.5
  • 1.0.4
  • 1.0.3
  • 1.0.2
  • 1.0.0
  • 0.1.2
  • 0.1.0
released Dec 19th 2019
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x, 2017.2.x, 2016.4.x
  • Puppet >= 4.10.4 < 7.0.0
  • CentOS
    ,
    RedHat
    ,
    OracleLinux
    ,
    Ubuntu
    ,
    OpenSUSE

Start using this module

Documentation

onyxpoint/gpasswd — version 1.1.1 Dec 19th 2019

puppet-gpasswd

Puppet-driven local group modification capabilities for Linux gpasswd

This is a module that enhances the native group type on systems supporting gpasswd to allow for the manipulation of group members.

Specifically, it adds the :manages_members attribute to the native Puppet group type. No alterations to your group code are required!

Examples

group { 'test':
  members => ['foo','bar','baz']
}

NOTES

The metadata for this module will only reflect OS releases that have either been tested by the Beaker acceptance tests or submitted via an issue.

License

Apache License 2.0

Contact

Trevor Vaughan tvaughan@onyxpoint.com

Support

Please log tickets and issues at our Gpasswd Github Site