phalconphp

Puppet PhalconPHP Module

Alex

pennycoders

20,542 downloads

8,984 latest version

0.5 quality score

Version information

  • 1.0.91 (latest)
  • 1.0.90
  • 1.0.89
  • 1.0.88
  • 1.0.87
  • 1.0.86
  • 1.0.85
  • 1.0.84
  • 1.0.81
  • 1.0.80
  • 1.0.79
  • 1.0.78
  • 1.0.75
  • 1.0.73
  • 1.0.72
  • 1.0.71
  • 1.0.70
  • 1.0.69
  • 1.0.65
  • 1.0.64
  • 1.0.62
  • 1.0.61
  • 1.0.60
  • 1.0.59
  • 1.0.58
  • 1.0.57
  • 1.0.56
  • 1.0.55
  • 1.0.54
  • 1.0.53
  • 1.0.52
  • 1.0.51
  • 1.0.50
  • 1.0.49
  • 1.0.48
  • 1.0.47
  • 1.0.46
  • 1.0.45
  • 1.0.44
  • 1.0.41
  • 1.0.40
  • 1.0.39
  • 1.0.38
  • 1.0.37
  • 1.0.36
  • 1.0.35
  • 1.0.34
  • 1.0.33
  • 1.0.32
  • 1.0.31
  • 1.0.30
  • 1.0.29
  • 1.0.28
  • 1.0.27
  • 1.0.26
  • 1.0.24
  • 1.0.23
  • 1.0.22
  • 1.0.21
  • 1.0.20
  • 1.0.19
  • 1.0.18
  • 1.0.17
  • 1.0.15
  • 1.0.14
  • 1.0.13
  • 1.0.12
  • 1.0.11
  • 1.0.10
  • 1.0.9
  • 1.0.8
  • 1.0.7
  • 1.0.6
  • 1.0.5
  • 1.0.4
  • 1.0.3
  • 1.0.2
  • 1.0.0
released Apr 17th 2014

Start using this module

Documentation

pennycoders/phalconphp — version 1.0.91 Apr 17th 2014

Phalcon Puppet module

Puppet is IT automation software that helps system administrators manage infrastructure throughout its lifecycle, from provisioning and configuration to orchestration and reporting. This is a Puppet module that installs Phalcon framework and optionally devtools, as well as all the other dependencies needed by them. I've tested this module both in production, and on a vagrant box, it worked flawlessly after the last fixes, in both cases. Don't hesitate to contribute, or open any issues.

Example usage

class { 'phalconphp':
    ensure_sys_deps => true,
    ensure => 'master', 
    install_devtool => true,
    devtools_version => 'master',
    install_zephir => false,
    compat_sys_deps => false,
    zephir_build => false,
    ini_file => 'phalcon.ini',
    debug => false,
    zephir_tmp_dir=>'/tmp/zephir'
}

Required parameters

ensure
ensure_sys_deps
install_devtools (needs to be se to true)
devtools_version

Parameters

ensure_sys_deps
ensure 
install_devtools
devtools_version
install_zephir
compat_sys_deps
zephir_build
ini_file
debug
zephir_tmp_dir

Prerequisites

This module can install everything for you, however, in order to be able to achieve that, a few other modules are required:

puppetlabs/stdlib
example42/yum 
puppetlabs/apt
example42/php 
example42/puppi

Gittip

Support the maintainer via Gittip

Notes

Values in the Usage example above are the default ones and although they can be changed, I strongly recommend to not change them unless you really need a more specific approach.

In regards to compat_sys_deps, see http://forum.phalconphp.com/discussion/1660/phalconphp-puppet-module-compiles-zephir-phalconphp-and-installs

This module has been rigurously tested on CentOS 6.5 x64

Devtools does not seem to be fully compatible with phalconphp 2.x

Until this issue is fixed, Zephir will have to be installed manually.

TODO

  • Add the ability to create phalcon projects via puppet
  • Add / test support for Debian platforms

Credits:

Special thanks to @ifrpl, for forking the repo (His improvements made me get started on getting this module sorted out the way it is now)