Forge Home

puppet_runner

Deploy puppet-runner and configure puppet runs

3,285 downloads

2,027 latest version

5.0 quality score

Version information

  • 1.1.0 (latest)
  • 1.0.1
  • 1.0.0
released Jul 23rd 2021
This version is compatible with:
  • Puppet Enterprise 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x
  • Puppet >= 6.21.0 < 8.0.0
  • , , , , , , , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'ploperations-puppet_runner', '1.1.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add ploperations-puppet_runner
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install ploperations-puppet_runner --version 1.1.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

ploperations/puppet_runner — version 1.1.0 Jul 23rd 2021

puppet_runner

Build Status

Deploy puppet-runner and configure puppet runs

Description

This module will deploy puppet-runner and schedule puppet runs that use it. puppet-runner is a wrapper for running the puppet agent that first checks that the environment an agent is configured to uses exists. If it does not then the agent is moved back to the production environment prior to running the puppet agent.

The scheduling is handled by the puppet_run_scheduler module.

Usage

The only paramert you need to set is the version of puppet-runner to deploy as the default in this module may not be in sync with the latest version of the application.

Reference

This module is documented via pdk bundle exec puppet strings generate --format markdown. Please see REFERENCE.md for more info.

Changelog

CHANGELOG.md is generated prior to each release via pdk bundle exec rake changelog. This proecss relies on labels that are applied to each pull request.

Limitations

There are some platforms supported by the pupet agent that this module does not yet support. A workaround for this may be added later.

Development

PRs are welcome!