kafka

approved
Puppet module for Kafka
Vox Pupuli

Vox Pupuli

puppet

267,913 downloads

1,680 latest version

5.0 quality score

Version information

  • 7.0.0 (latest)
  • 6.0.0
  • 5.3.0
  • 5.2.0
  • 5.1.0
  • 5.0.1
  • 5.0.0
  • 4.0.0
  • 3.2.0
  • 3.1.0
  • 3.0.0
  • 2.3.0
  • 2.2.0
  • 2.1.0
  • 2.0.0
  • 1.0.3
  • 1.0.2
  • 1.0.1
released Jun 3rd 2020
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x
  • Puppet >= 5.5.8 < 7.0.0
  • CentOS
    ,
    RedHat
    ,
    Ubuntu
    ,
    Debian
    ,
    SLES

Start using this module

Tags: pubsub, kafka

Documentation

puppet/kafka — version 7.0.0 Jun 3rd 2020

Kafka module for Puppet

Build Status Puppet Forge Puppet Forge - downloads Puppet Forge - endorsement Puppet Forge - scores

Table of Contents

  1. Overview
  2. Module Description - What the module does and why it is useful
  3. Setup - The basics of getting started with Kafka
  4. Usage - Configuration options and additional functionality
  5. Reference - An under-the-hood peek at what the module is doing and how
  6. Limitations - OS compatibility, etc.
  7. Development - Guide for contributing to the module

Overview

The Kafka module for managing the installation and configuration of Apache Kafka.

Module Description

The Kafka module for managing the installation and configuration of Apache Kafka: it's brokers, producers and consumers.

Setup

What Kafka affects

Installs the Kafka package and creates a new service.

Setup requirements

This module has the following dependencies:

Beginning with Kafka

To successfully install Kafka using this module you need to have Apache ZooKeeper already running at localhost:2181. You can specify another ZooKeeper host:port configuration using the config hash of the kafka::broker class.

The default configuration installs Kafka 0.11.0.3 binaries with Scala 2.11:

  class { 'kafka': }

If you want a Kafka broker server that connects to ZooKeeper listening on port 2181:

  class { 'kafka::broker':
    config => {
      'broker.id'         => '0',
      'zookeeper.connect' => 'localhost:2181'
    }
  }

Usage

You can specify different Kafka binaries packages versions to install. Please take a look at the different Scala and Kafka versions combinations at the Apache Kafka Website

Installing Kafka version 1.1.0 with scala 2.12

We first install the binary package with:

  class { 'kafka':
    version => '1.1.0',
    scala_version => '2.12'
  }

Then we set a minimal Kafka broker configuration with:

  class { 'kafka::broker':
    config => {
      'broker.id'         => '0',
      'zookeeper.connect' => 'localhost:2181'
    }
  }

Reference

The reference documentation of this module is generated using puppetlabs/puppetlabs-strings.

Limitations

This module only supports Kafka >= 0.9.0.0.

This module is tested on the following platforms:

  • Debian 8
  • Debian 9
  • Debian 10
  • Ubuntu 16.04
  • Ubuntu 18.04
  • CentOS 6
  • CentOS 7

It is tested with the OSS version of Puppet (>= 5.5) only.

Development

This module has grown over time based on a range of contributions from people using it. If you follow these contributing guidelines your patch will likely make it into a release a little more quickly.

Author

This module is maintained by Vox Pupuli. It was originally written and maintained by Liam Bennett.