make

approved
Manage make

Vox Pupuli

puppet

324,850 downloads

11,474 latest version

5.0 quality score

Version information

  • 3.0.0 (latest)
  • 2.1.1
  • 2.1.0
  • 2.0.0
  • 1.1.0
  • 1.0.1
released Jul 29th 2019
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x
  • Puppet >= 5.5.8 < 7.0.0
  • RedHat
    ,
    CentOS
    ,
    OracleLinux
    ,
    Scientific
    ,
    SLES
    ,
    SLED
    ,
    Ubuntu

Start using this module

Documentation

puppet/make — version 3.0.0 Jul 29th 2019

#make

Puppet Forge Build Status Github Tag Gitter Puppet Forge Downloads Puppet Forge Endorsement

####Table of Contents

  1. Overview
  2. Usage - Configuration options and additional functionality
  3. Parameters
  4. Limitations - OS compatibility, etc.
  5. Development - Guide for contributing to the module

##Overview

Installs the 'make' package.

##Usage

  include ::make

To override the package name,

  class { '::make':
    package_name => 'gmake',
  }

##Parameters


package_name (type: String)

Name of package for make.

  • Default: 'make'

####package_ensure (type: String) Value of ensure attribute for make package.

  • Default: 'present'

##Limitations

Supports Puppet v3 and v4 against a matrix of Ruby versions documented in .travis.yml on the following platforms.

  • Debian 7
  • EL 5
  • EL 6
  • EL 7
  • SLES/SLED 10
  • SLES/SLED 11
  • SLES/SLED 12
  • Ubuntu 12.04
  • Ubuntu 14.04
  • Ubuntu 16.04

##Development

To contribute, fork https://github.com/voxpupuli/puppet-make.git, make a branch for your changes, and file a pull request.

##Contributors

Thank you to all of our https://github.com/voxpupuli/puppet-make/graphs/contributors.