Forge Home

complyadm

Install and manage Security Compliance Management

174 downloads

4 latest version

Security Compliance Management is now included with Puppet Enterprise

Security Compliance Management lets you monitor and report on security and compliance configurations in your Puppet-managed infrastructure. It requires Puppet Enterprise and is accessed through the Security Compliance Management Console in Puppet Enterprise.

For more information about this module, reach out to your Puppet by Perforce account executive or sales engineer. The Puppet team is available to assist you with the installation process and answer any questions.


Security Compliance Enforcement, a premium feature also available for Puppet Enterprise and Open Source Puppet, automatically enforces security configurations aligned to CIS Benchmarks and DISA STIGs.

Learn more about Security Compliance Enforcement       Go to module page:  Windows | Linux

Version information

  • 3.0.3 (latest)
  • 3.0.2
  • 3.0.1
  • 3.0.0 (deleted)
released Jun 7th 2024
This version is compatible with:
  • Puppet Enterprise 2023.2.x, 2023.1.x, 2023.0.x, 2021.7.x, 2021.6.x, 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x
  • Puppet >= 6.21.0 < 8.0.0
  • , , , , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation

Add this module to your Puppetfile:

mod 'puppetlabs-complyadm', '3.0.3'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add puppetlabs-complyadm
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install puppetlabs-complyadm --version 3.0.3

Documentation

puppetlabs/complyadm — version 3.0.3 Jun 7th 2024

complyadm

For details on how to use this set of bolt plans, please refer to the documentation at https://www.puppet.com/docs/comply/3.x/comply.html