Forge Home

detect_wannacry

This module is intended to detect WannaCry vulnerabilities on your machine.

19,259 downloads

13,054 latest version

4.6 quality score

Version information

  • 0.6.2 (latest)
  • 0.6.1
  • 0.6.0
  • 0.5.0
  • 0.4.0
  • 0.3.0
  • 0.2.0
  • 0.1.0
released Nov 13th 2017
This version is compatible with:

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'puppetlabs-detect_wannacry', '0.6.2'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add puppetlabs-detect_wannacry
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install puppetlabs-detect_wannacry --version 0.6.2

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

puppetlabs/detect_wannacry — version 0.6.2 Nov 13th 2017

detect_wannacry

Table of Contents

  1. Description
  2. Reference - An under-the-hood peek at what the module is doing and how

Description

This module is intended to detect WannaCry vulnerabilities on your machine.

Reference

Facts

  • wannacry_vulnerable - Whether the machine is vulnerable to the WannaCry exploit. Either 'true' or 'false'.