pe_gem

deprecated
Adds provider for the Puppet Enterprise Ruby gem manager.
Puppet

Puppet

puppetlabs

2,761,809 downloads

1,393,124 latest version

4.4 quality score

Version information

  • 0.2.0 (latest)
  • 0.1.2
  • 0.1.1
  • 0.1.0
  • 0.0.1
released Jan 28th 2016
This module has been deprecated by its author since May 15th 2020.

Start using this module

Tags: pe, gem

Documentation

puppetlabs/pe_gem — version 0.2.0 Jan 28th 2016

puppetlabs pe_gem module

This module provides management of Ruby gems for Puppet Enterprise.

package { 'json':
  ensure   => present,
  provider => pe_gem,
}

This uses puppet gem as a parent and simply alters the gem path to /opt/puppet/bin/gem.

Deprecation for Puppet >= 4.0

As of Puppet 4.0, this module has been deprecated. Please use Puppet 4.0's built-in puppet_gem provider instead.