jetbrains_licenseserver

Puppet module to download and install JetBrains License Server

Rickard von Essen

rickard

9,274 downloads

9,274 latest version

3.4 quality score

Version information

  • 0.1.0 (latest)
released Jan 7th 2014

Start using this module

Documentation

rickard/jetbrains_licenseserver — version 0.1.0 Jan 7th 2014

JetBrains License Server

This is a puppet module to install jetbrains_licenseserver module. See JetBrains License Server

Requires

Modules: gini-archive >= 0.2.0

Packages:

  • Java 6 JRE/JDK or later
  • unzip

Usage

To use the default version:

package { 'java-1.7.0-openjdk':
  ensure => installed,
}
package { 'unzip':
  ensure => installed,
}

include jetbrains_licenseserver

To select a specific version:

class { jetbrains_licenseserver:
  version        => '328',
  tomcat_version => '6.0.30',
}

License

This puppet module is licensed under the Apache License, Version 2.0

Contact

Rickard von Essen rickard.von.essen@gmail.com

Support

Please log tickets and issues at our GitHub issues