puppet_r

A module for installing R

Session M, Inc.

sessionm

8,778 downloads

8,675 latest version

1.6 quality score

Version information

  • 0.0.2 (latest)
  • 0.0.1
released Feb 26th 2015
This version is compatible with:
  • RedHat
    ,
    Ubuntu

Start using this module

Documentation

sessionm/puppet_r — version 0.0.2 Feb 26th 2015

Puppet R module

This module gives you the ability to install R, but also R packages.

Usage

To install R you need to include the class...

class { '::r': }

To install a specific version of R...

class { '::r': version => '3.2.1' }

Then define any packages you want to be installed...

::r::package { 'ggplot2': }
::r::package { 'reshape': }

To ensure that dependencies are resolved for packages...

::r::package { 'reshape': dependencies => true, }

To configure R for use with Java packages...

include ::r::java_conf