crypto_policy

pdk
Manage, and provide information about, the system-wide crypto policies

SIMP

simp

1,786 downloads

452 latest version

4.7 quality score

Version information

  • 0.1.4 (latest)
  • 0.1.3
  • 0.1.2
  • 0.1.1
  • 0.1.0
released Jan 1st 2021
This version is compatible with:
  • Puppet Enterprise 2021.0.x, 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x
  • Puppet >= 5.0.0 < 8.0.0
  • CentOS
    ,
    OracleLinux
    ,
    RedHat

Start using this module

Documentation

simp/crypto_policy — version 0.1.4 Jan 1st 2021

License CII Best Practices Puppet Forge Puppet Forge Downloads Build Status

pupmod-simp-crypto_policy

Table of Contents

Description

Manage, and provide information about, the system-wide crypto policies.

See update-crypto-policy(8) for additional information.


WARNING There are issues with crypto-policies < 20190000 which may render a FIPS

system inaccessible.

Setup

What crypto_policy affects

Manages the system-wide crypto policy.

Applications may opt-in, or out, of usage by following the steps outlined in update-crypto-policy(8).

Usage

class { 'crypto_policy': }

Reference

See REFERENCE.md for the full module reference.

Limitations

SIMP Puppet modules are generally intended for use on Red Hat Enterprise Linux and compatible distributions, such as CentOS. Please see the metadata.json file for the most up-to-date list of supported operating systems, Puppet versions, and module dependencies.

Development

Please read our Contribution Guide.

If you find any issues, they can be submitted to our JIRA.