wordpress

Wordpress module for EL 6

Dustin Morgan

swizzley88

8,300 downloads

7,631 latest version

4.3 quality score

Version information

  • 0.1.2 (latest)
  • 0.1.1
  • 0.1.0
released Sep 14th 2015
This version is compatible with:
  • Puppet Enterprise >= 3.7.0 < 2015.3.0
  • Puppet >= 3.0.0 < 5.0.0
  • RedHat

Start using this module

Documentation

swizzley88/wordpress — version 0.1.2 Sep 14th 2015

wordpress

Puppet Forge

Table of Contents

  1. Overview
  2. Module Description
  3. Setup
  4. Usage
  5. Requirements
  6. Compatibility
  7. Limitations
  8. Development

Overview

This module sets up the L.A.M.P server Wordpress for blogging and such.

Module Description

This module is designed to be a simple and minimalistic... a one and done setup for wordpress on EL systems.

Setup

Modify or inherit parameters in params.pp to your liking. Enable php and epel repo is true by default.

Usage

include ::wordpress

Requirements

puppetlabs/mysql

puppetlabs/apache

Compatibility

  • RHEL 6
  • CentOS 6

Limitations

This module has been tested on:

  • CentOS 6

Development

Any updates or contibutions are welcome.

Report any issues with current release, as any input will be considered valuable.

TODO

  • add other OS support
Contact

Email: morgan@aspendenver.org

WWW: www.aspendenver.org

Github: https://github.com/swizzley