Forge Home

munge

pdk
munge Puppet module

308,723 downloads

228 latest version

5.0 quality score

Version information

  • 4.0.0 (latest)
  • 3.2.0
  • 3.1.0
  • 3.0.0
  • 2.4.0
  • 2.3.0
  • 2.2.0
  • 2.1.0
  • 2.0.0
  • 1.1.0
  • 1.0.0
  • 0.1.1
  • 0.1.0
  • 0.0.2
  • 0.0.1
released Nov 25th 2021
This version is compatible with:
  • Puppet Enterprise 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x
  • Puppet >= 6.1.0 < 8.0.0
  • RedHat
    ,
    CentOS
    ,
    Rocky
    ,
    Debian
    ,
    Ubuntu

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'treydock-munge', '4.0.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add treydock-munge
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install treydock-munge --version 4.0.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download
Tags: munge

Documentation

treydock/munge — version 4.0.0 Nov 25th 2021

puppet-munge

Puppet Forge Build Status

Table of Contents

  1. Overview
  2. Usage - Configuration options
  3. Reference - Parameter and detailed reference to all options
  4. Limitations - OS compatibility, etc.
  5. Development - Guide for contributing to the module
  6. TODO
  7. Additional Information

Overview

This module manages MUNGE.

Usage

munge

Manage munge and define a site specific munge.key

class { 'munge':
  munge_key_source  => 'puppet:///modules/site_munge/munge.key',
}

Reference

http://treydock.github.io/puppet-munge/

Limitations

This module has been tested on:

  • CentOS/RedHat 6 x86_64
  • CentOS/RedHat 7 x86_64

Development

Testing

Testing requires the following dependencies:

  • rake
  • bundler

Install gem dependencies

bundle install

Run unit tests

bundle exec rake test

If you have Vagrant >= 1.2.0 installed you can run system tests

bundle exec rake beaker

TODO

Further Information