Trey Dockendorf

treydock

16,070 downloads

1,538 latest version

5.0 quality score

Version information

  • 1.8.0 (latest)
  • 1.7.0
  • 1.6.0
  • 1.5.0
  • 1.4.3
  • 1.4.2
  • 1.4.1
  • 1.4.0
  • 1.3.1
  • 1.3.0
  • 1.2.0
  • 1.1.1
  • 1.1.0
  • 1.0.0
  • 0.0.3
  • 0.0.2
  • 0.0.1
released Oct 28th 2019
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x
  • Puppet >= 5.0.0 < 7.0.0
  • RedHat
    ,
    CentOS
    ,
    Scientific

Start using this module

Documentation

treydock/pcp — version 1.8.0 Oct 28th 2019

puppet-module-pcp

Puppet Forge Build Status

  1. Overview
  2. Usage - Configuration options
  3. Reference - Parameter and detailed reference to all options
  4. Compatibility
  5. Development - Guide for contributing to the module

Overview

This module manages Performance Co-Pilot (PCP)

Only PCP >= 3.11.3 is supported

Usage

To install PCP to log locally

class { 'pcp': }

Example of using PCP without default logger and pmie as well as disabling pmlogger log archival

class { '::pcp':
  include_default_pmlogger => false,
  include_default_pmie     => false,
  pmlogger_daily_args      => '-M -k forever',
}

Define a new primary logger that logs to a shared location

pcp::pmlogger { 'supremm':
  ensure         => 'present',
  hostname       => 'LOCALHOSTNAME',
  primary        => true,
  socks          => false,
  log_dir        => '/data/supremm/pmlogger/LOCALHOSTNAME',
  args           => '-r -c config.default',
}

Install and enable a PMDA

pcp::pmda { 'slurm': }

Reference

http://treydock.github.io/puppet-module-pcp/

Compatibility

This module only works with PCP >= 3.11.3

Tested using

  • CentOS 6
  • CentOS 7

Development

Testing

Testing requires the following dependencies:

  • rake
  • bundler

Install gem dependencies

bundle install

Run unit tests

bundle exec rake test

If you have Vagrant >= 1.2.0 installed you can run system tests

bundle exec rake beaker