Filters
clear
Operating System
Puppet Version
Puppet Enterprise Version
Supported/Approved

Note: Modules that do not have information about compatibility in their metadata will not appear in filtered results.

Authors: Learn how to add compatibility to your modules.

  • avatar

    puppetlabs/postgresql

    • supported

    Offers support for basic management of PostgreSQL databases.

  • avatar

    puppetlabs/mysql

    • tasks
    • supported

    Installs, configures, and manages the MySQL service.

  • avatar

    locp/cassandra Deprecated

    Installs Cassandra & DataStax Agent on RHEL/Ubuntu/Debian.

  • avatar

    puppetlabs/mongodb Deprecated

    Installs MongoDB on RHEL/Ubuntu/Debian.

  • avatar

    puppetlabs/mssql

    Puppet Labs Microsoft SQL Server Module

  • avatar

    biemond/oradb

    Oracle Database 11.2, 12.1 & 12.2 for Linux & Solaris plus ASM, Client, Enterprise Manager & GoldenGate

  • avatar

    mlambrichs/neo4j

    A module installing and configuring Neo4j community or enterprise editions.

  • avatar

    puppetlabs/sqlserver

    • supported

    The `sqlserver` module installs and manages MS SQL Server 2012, 2014, 2016 and 2017 on Windows systems.

  • avatar

    puppetlabs/sqlite

    Installs, configures, and manages the SQLite service.

  • avatar

    hajee/oracle

    the custom types needed to manage the basic setup of an Oracle database

Showing 1 - 10 of 55 results