ubuntuzilla

deprecated
Module for installing the Ubuntuzilla repository

Ben S

juniorsysadmin

10,741 downloads

5,833 latest version

4.3 quality score

Version information

  • 0.1.0 (latest)
  • 0.0.5
  • 0.0.4
  • 0.0.3
  • 0.0.2
released Dec 17th 2016
This version is compatible with:
  • Puppet Enterprise 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >=3.8.7 < 5.0.0
  • Debian
    ,
    Ubuntu
This module has been deprecated by its author since Feb 11th 2021.

The reason given was: No longer maintained

The author has suggested juniorsysadmin-ubuntuzilla as its replacement.

Start using this module

Documentation

juniorsysadmin/ubuntuzilla — version 0.1.0 Dec 17th 2016

ubuntuzilla

Table of Contents

  1. Overview
  2. Usage
  3. Limitations
  4. Development

Overview

This module installs and enables the Ubuntuzilla deb repository. When run on a non-Debian osfamily it exits with no action performed.

Build
Status

Usage

include  '::ubuntuzilla'

or to use your own Ubuntuzilla mirror:

class { '::ubuntuzilla':
  key        => 'A1234567',
  key_server => 'keyserver.server.com',
  location   => 'ubuntuzilla.mirror.com',
}

Parameters

The following parameters are available in the ubuntuzilla module:

include_src

Used by apt::source. Defaults to false.

key

Used by apt::source. Defaults to the official Ubuntuzilla one.

key_server

Used by apt::source. Defaults to keyserver.ubuntu.com

location

Location of Ubuntuzilla repository. Defaults to http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt

release

Used by apt::source. Defaults to all.

repos

Used by apt::source. Defaults to main.

Limitations

This module has received limited testing on:

  • Debian 6/7
  • Ubuntu 10.04/12.04/14.04

against Puppet 3.8.7 and Puppet 4.x

Development

Patches are welcome.