zendguardloader

Puppet module to install Zend Guard Loader for PHP 5.3 and PHP 5.4 (apache-linux-x64). Originally forked from Proud Sourcing GmbH.

Albert Mikaelyan

Tahvok

7,819 downloads

7,387 latest version

4.6 quality score

Version information

  • 1.0.5 (latest)
  • 1.0.4
  • 1.0.3
  • 1.0.2
  • 1.0.1
  • 1.0.0
released Mar 25th 2015
This version is compatible with:
  • RedHat
    ,
    Ubuntu

Start using this module

Documentation

Tahvok/zendguardloader — version 1.0.5 Mar 25th 2015

Puppet module: zendguardloader

Puppet module to install Zend Guard Loader for PHP 5.3 and PHP 5.4 (64-bit systems).

Usage

  • Install using default options: PHP 5.3, automatic detection of Operating System and restart of apache service upon change:

      class { 'zendguardloader': }
    
  • You can define php version, apache modules, php conf.d directory and more:

      class { 'zendguardloader':
              php_version     => "5.4",
              php_modules_dir   => "",
              apache_php_dir    => ""
      }
    

Supported Operating Systems

  • RedHat/Centos 5-7
  • Debian/Ubuntu (Not tested)
  • OpenSuSE (Not tested)