cutover

Uninstalls existing puppet agent, and runs simplified installer for cutover upgrades.

Chris Matteson

chrismatteson

7,555 downloads

7,350 latest version

3.1 quality score

Version information

  • 1.0.2 (latest)
  • 1.0.1
  • 1.0.0
released Sep 6th 2015
This version is compatible with:
  • Puppet Enterprise >= 2.0.0 < 4.0.0
  • Puppet >= 3.0.0 < 4.0.0
  • RedHat
    ,
    CentOS
    ,
    OracleLinux
    ,
    Scientific
    ,
    SLES
    ,
    Debian
    ,
    Ubuntu
    ,
    Solaris
    ,
    AIX

Start using this module

Documentation

chrismatteson/cutover — version 1.0.2 Sep 6th 2015

puppet-module-cutover

The purpose of this module is to support cutover upgrades of puppet open source and Puppet Enterprise by finding and uninstalling any version of puppet currently installed then installing the all in one agent. Currently there is support for Puppet Enterprise >= 2.0.0 and puppet open source >= 3.0.0 for *nix based agents. However this will soon be expanded to include Windows platforms.