supervisor

pdk
Installs and configures Supervisor.

DomKrm

domkrm

1,328 downloads

1,045 latest version

5.0 quality score

Version information

  • 1.2.0 (latest)
  • 1.1.0
  • 1.0.0
released Nov 1st 2019
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x, 2017.2.x, 2016.4.x
  • Puppet >= 4.10.0 < 7.0.0
  • Debian
    ,
    Ubuntu

Start using this module

Documentation

domkrm/supervisor — version 1.2.0 Nov 1st 2019

Supervisor module for Puppet

Module for Supervisor installation and configuration.

This module is currently tested only on Ubuntu. But it should work on Debian (and maybe other systems) also.

Usage

supervisor::program { 'worker':
  command     => 'php worker.php',  (required)
  autostart   => true,              (default)
  autorestart => true,              (default)
  numprocs    => 1,                 (default)
  user        => 'root'             (default)
}

Installation

As soon as you create a program the Supervisor package will be installed.

Purge

This module purges all programs which are not managed by puppet.