lsb

deprecated
Puppet module for lsb

Example42

example42

9,792 downloads

7,625 latest version

3.8 quality score

Version information

  • 2.0.16 (latest)
  • 2.0.14
  • 2.0.13
  • 2.0.12
  • 2.0.11
released Jun 30th 2015
This module has been deprecated by its author since Oct 29th 2019.

The reason given was: No longer maintained

The author has suggested example42-tp as its replacement.

Start using this module

Tags: lsb, example42

Documentation

example42/lsb — version 2.0.16 Jun 30th 2015

Puppet module: lsb

DEPRECATION NOTICE

This module is no more actively maintained and will hardly be updated.

Please find an alternative module from other authors or consider Tiny Puppet as replacement.

If you want to maintain this module, contact Alessandro Franceschi

This is a Puppet module for lsb It provides only package installation and management for minimal lsb setup in order to have lsb based facts installing the minimun number of dependencies.

Based on Example42 layouts by Alessandro Franceschi / Lab42

Official site: http://www.example42.com

Official git repository: http://github.com/example42/puppet-lsb

Released under the terms of Apache 2 License.

This module requires the presence of Example42 Puppi module in your modulepath.

USAGE - Basic management

  • Install lsb

      class { 'lsb': }
    
  • Install a specific version of lsb package

      class { 'lsb':
        version => '1.0.1',
      }
    
  • Remove lsb

      class { 'lsb':
        absent => true
      }
    
  • Module dry-run: Do not make any change on all the resources provided by the module

      class { 'lsb':
        noops => true
      }
    
  • Automatically include a custom subclass

      class { 'lsb':
        my_class => 'example42::my_lsb',
      }
    

Build Status