Forge Home

powershell_net4

Ensure PowerShell uses .NET 4.x if available

9,392 downloads

9,392 latest version

2.5 quality score

Version information

  • 0.1.0 (latest)
released Feb 26th 2015
This version is compatible with:

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'ferventcoder-powershell_net4', '0.1.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add ferventcoder-powershell_net4
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install ferventcoder-powershell_net4 --version 0.1.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

ferventcoder/powershell_net4 — version 0.1.0 Feb 26th 2015

powershell_net4

Table of Contents

  1. Overview
  2. Module Description - What the module does and why it is useful
  3. Setup - The basics of getting started with powershell_net4
  4. Usage - Configuration options and additional functionality
  5. Limitations - OS compatibility, etc.
  6. Development - Guide for contributing to the module

Overview

Ensure that PowerShell is using the latest .NET Framework available.

Module Description

This module ensures that a config file is created next to PowerShell to ensure that it will use the latest .NET framework available.

Setup

What powershell_net4 affects

  • C:\Windows\system32\WindowsPowerShell\v1.0\powershell.exe.config

Usage

include powershell_net4

Limitations

This applies to Windows only.

Development

Issues are great. Pull requests are awesome!