cube

Install and manage cube

Gareth Rushgrove

garethr

9,396 downloads

9,147 latest version

3.0 quality score

Version information

  • 0.1.0 (latest)
  • 0.0.1
released Feb 9th 2013

Start using this module

Documentation

garethr/cube — version 0.1.0 Feb 9th 2013

A Puppet module for managing the installation and configuration of Cube.

Build
Status

Usage

For experimenting you're probably fine just with:

include 'cube'

Configuration

The module should allow overriding of all of cube's settings. The following is an exampe also showing the default values, based on those in the npm package.

class { 'cube':
  cube_source         => 'cube' # default npm module; can be overridden with tarball url
  collector_http_port => 1080,
  collector_udp_port  => 1180,
  evaluator_port      => 1081,
  mongo_host          => '127.0.0.1',
  mongo_port          => 27017,
  mongo_database      => 'cube_development',
  mongo_username      => false,
  mongo_password      => false
}

Requirement

Cube requires both mongodb and nodejs/npm to be installed and runned. Although this module does not install mongodb, modules available from puppetlabs do. They are included as dependencies in the Modulefile. To install Mongo you can use:

class { 'mongodb':
  enable_10gen => true,
}