Forge Home

snapd

Install and manage the snapd service for installing and managing snap packages.

24,870 downloads

22,353 latest version

5.0 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 1.1.0 (latest)
  • 1.0.0
released Sep 11th 2018
This version is compatible with:
  • Puppet Enterprise 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 4.0.0 < 6.0.0
  • Archlinux,
This module has been deprecated by its author since Jul 22nd 2021.

Start using this module

Documentation

kemra102/snapd — version 1.1.0 Sep 11th 2018

snapd

Table of Contents

  1. Description
  2. Setup - The basics of getting started with snapd
  3. Usage - Configuration options and additional functionality
  4. Reference - An under-the-hood peek at what the module is doing and how
  5. Limitations - OS compatibility, etc.
  6. Development - Guide for contributing to the module

Description

This module manages the snapd package and service. snapd is a tool that enables the installation of snap packages on a Linux system.

See the official website for more detailed information.

Setup

What snapd affects

This module currently manages the following items:

  • The snapd package.
  • The snapd service.

Usage

To use this module simply include it:

class { 'snapd': }

or

include ::snapd

Install packages using the package provider

package { ['phpstorm', 'atom']:
  ensure   => latest,
  provider => snap,
}

package { 'spotify':
  ensure   => purged,
  provider => snap,
}

Unsupported Operating Systems

If your OS is not listed in Limitations it may still work regardless.

Debian Sid for example should work without any changes.

Reference

snapd

This is the main class. Currently it has no configurable items.

Limitations

Supported Operating Systems:

  • Arch Linux
  • Ubuntu 16.04 & 16.10

Supported Puppet Versions:

  • Puppet Enterprise >= 2015.2
  • Puppet Open Source >= 4.0.0

Provider

We provide a basic package provider which allows installs and removes, we will need to add latest,query and update support in the future.

Development

To contribute to the development of this module please raise a pull request.

Particular help is currently highly desired particularly on the following items:

  • Package provider query,latest and update functionality
  • Support for more Operating Systems.
  • More testing.