Forge Home

dellperc

Dell PERC module

3,102 downloads

157 latest version

5.0 quality score

Version information

  • 1.1.0 (latest)
  • 1.0.1
  • 1.0.0
released Aug 5th 2022
This version is compatible with:
  • Puppet Enterprise 2021.6.x, 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x
  • Puppet >= 6.21.0 < 8.0.0
  • , , , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'lsst-dellperc', '1.1.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add lsst-dellperc
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install lsst-dellperc --version 1.1.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

lsst/dellperc — version 1.1.0 Aug 5th 2022

dellperc

  • CI

Table of Contents

  1. Overview
  2. Usage - Configuration options and additional functionality

Overview

Provides the has_dellperc fact used to determine if a system has a Dell PERC RAID controller installed.

Usage

if $facts['has_dellperc'] {
  notice("Dude, you're getting a Dell... rebranded LSI RAID controller.")
}