consular

deprecated
Basic module to manage Consular
Praekelt Foundation

Praekelt Foundation

praekeltfoundation

11,770 downloads

6,393 latest version

5.0 quality score

Version information

  • 0.2.4 (latest)
  • 0.2.3
  • 0.2.2
  • 0.2.1
  • 0.2.0
  • 0.1.1
released Jul 3rd 2019
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >=3.4.0
  • Ubuntu
This module has been deprecated by its author since May 15th 2020.

Start using this module

Documentation

praekeltfoundation/consular — version 0.2.4 Jul 3rd 2019

puppet-consular

Puppet module for managing Consular.

DEPRECATED: Consular has been deprecated and it, as well as this Puppet module, will no longer be maintained.

This is a very simple module and does not include a lot of features. It is only compatible with certain versions of Ubuntu (those that use Upstart as their init system) and has only been tested on Ubuntu 14.04.

NOTE: We currently provide Consular packages from a PPA. This is a temporary PPA that is managed manually by a single individual in his personal capacity. It needs to be replaced with a better one that gets automated package updates and such.

Usage

class { 'consular':
  package_ensure => 'latest',
  host           => $::ipaddress_eth0,
  port           => 7070,
  consul         => 'http://127.0.0.1:8500',
  marathon       => 'http://127.0.0.1:8080',
  sync_interval  => 300,
  purge          => true,
}

For a full list of options see the manifest source.