drush

This module installs Drush, a command line utility for Drupal.
PreviousNext

PreviousNext

previousnext

44,164 downloads

31,978 latest version

5.0 quality score

Version information

  • 0.1.2 (latest)
  • 0.1.1
  • 0.1.0
  • 0.0.4
  • 0.0.3
  • 0.0.2
  • 0.0.1
released Jul 3rd 2019
This version is compatible with:
  • Ubuntu
    ,
    CentOS

Start using this module

Documentation

previousnext/drush — version 0.1.2 Jul 3rd 2019

puppet-drush

Build
Status

This module installs Drush, a command line shell and Unix scripting interface for Drupal.

Installation

Using the Puppet Module Tool, install the previousnext/drush module by running the following command:

puppet module install previousnext/drush

Otherwise, clone this repository and make sure to install the proper dependencies (puppet-composer):

git clone git://github.com/previousnext/puppet-drush.git modules/drush

Important: the right puppet-composer module is willdurand/puppet-composer. Do not use any other puppet-composer module.

Usage

Include the drush::drush class:

include drush::drush

You can specify the version you want to install:

drush::drush { 'drush8':
  version => '8',
}

You can specify the link name you want to get, and the target directory (aka where to install Drush):

drush::drush { 'drush':
  link_name => '/usr/local/bin/drush',
  target_dir   => '/usr/local'
}

You can specify a particular user that will be the owner of the Drush directory:

drush::drush { 'drush7':
  user => 'foo',
}

It is possible to install multiple versions side by side, but remember to pass a custom link name for each if you do:

drush::drush { 'drush8':
  version      => '8',
  link_name => '/usr/local/bin/drush8',
}

drush::drush { 'drush7':
  link_name => '/usr/local/bin/drush7',
}

Or you can use hiera to specify drush resources:

---
classes:
  - drush

drush:
  drush62
    version:   '6.2'
    link_name: '/usr/local/bin/drush-legacy'
  drush67
    version:   '6.7'
  drush7
    version:   '7'
    link_name: '/usr/local/bin/drush7'
  drush8
    version:   '8'
    link_name: '/usr/local/bin/drush8'

Running the tests

Install the dependencies using Bundler:

BUNDLE_GEMFILE=.gemfile bundle install

Run the following command:

BUNDLE_GEMFILE=.gemfile bundle exec rake validate lint spec SPEC_OPTS='--format documentation'

License

puppet-drush is released under the License. See the bundled LICENSE file for details.

Acknowledgement

puppet-drush is based on puppet-composer by William Durand.