puppetr

A module for installing R, forked from forward3d/puppet-r
tallsam

tallsam

tallsam

6,162 downloads

6,162 latest version

3.0 quality score

Version information

  • 0.0.1 (latest)
released Mar 29th 2016
This version is compatible with:
  • RedHat

Start using this module

Tags: r, install, redhat

Documentation

tallsam/puppetr — version 0.0.1 Mar 29th 2016

Puppet R module

This module gives you the ability to install R, but also R packages.

Usage

To install R you need to include the class...

class { 'r': }

Then define any packages you want to be installed...

r::package { 'ggplot2': }
r::package { 'reshape': }

To define a package, and all required dependencies, use this format: r::package { 'reshape': dependencies => true, }

on RHEL/CentOS machines, make sure you have EPEL enabled, or R won't install properly.