Forge Home

nrpe

Puppet module to install, deploy and configure nrpe.

9,613 downloads

4,731 latest version

5.0 quality score

Version information

  • 3.0.2 (deleted)
  • 3.0.1 (deleted)
  • 1.0.8 (latest)
  • 1.0.7
  • 1.0.6
  • 1.0.5
  • 1.0.4
  • 1.0.3
  • 1.0.2
  • 1.0.1
  • 1.0.0
released Jul 23rd 2018
This version is compatible with:
  • Puppet Enterprise 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 2.7.0 <= 6.0.0
  • Debian
    ,
    Ubuntu
    ,
    CentOS

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'vpgrp-nrpe', '1.0.8'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add vpgrp-nrpe
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install vpgrp-nrpe --version 1.0.8

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

vpgrp/nrpe — version 1.0.8 Jul 23rd 2018

puppet-nrpe License badge

  1. Overview
  2. Description
  3. Setup
  4. Usage
  5. Limitations
  6. Development
  7. Miscellaneous

Overview

NRPE allows you to remotely execute Nagios plugins on other Linux/Unix machines. This allows you to monitor remote machine metrics (disk usage, CPU load, etc.). NRPE can also communicate with some of the Windows agent addons, so you can execute scripts and check metrics on remote Windows machines as well.

github.com/nagiosenterprises/nrpe

Description

Puppet module to install, deploy and configure nrpe.

Setup

Copy this module in your modules folder without puppet- in the name.

or

puppet module install vpgrp-nrpe

Usage

class { 'nrpe':
  package       => true,
  service       => true,
  allowed_hosts => [ '10.0.0.0/8', '192.168.0.0/16' ],
}
nrpe::plugin {
  'check_memory':
    source => 'puppet:///modules/nrpe/check_memory'
}

nrpe::command {
  'check_memory':
    command => 'check_memory'
}

Limitations

So far, this is compatible with Debian, RedHat, and other derivatives.

Development

Please read carefully CONTRIBUTING.md before making a merge request.

Miscellaneous

    ╚⊙ ⊙╝
  ╚═(███)═╝
 ╚═(███)═╝
╚═(███)═╝
 ╚═(███)═╝
  ╚═(███)═╝
   ╚═(███)═╝