avatar

puppetlabs/java

by: Puppet
  • pdk
  • supported
Installs the correct Java package on various platforms.
Latest version is compatible with:
  • Puppet Enterprise 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x
  • Puppet >= 5.5.10 < 7.0.0
    • RedHat,
    • Ubuntu,
    • Debian,
    • SLES,
    • Scientific,
    • CentOS,
    • OracleLinux

Start using this module:

new! Bolt

Add this declaration to your Puppetfile:

Then run:

r10k or Code Manager

Add this declaration to your Puppetfile:

Manual installation

Manually install this module with Puppet module tool:

10,809,802
Latest version: 71,227

More from Puppet

Open source, agentless, limitless

The easiest way to ramp your automation efforts

learn more >

Deploy code with confidence

Assess the impact of proposed changes with Impact Analysis

learn more >