phantomjs

Simple puppet module that installs PhantomJS - headless WebKit scriptable with a Javascript API.

3fs

3fs

113,862 downloads

36,042 latest version

4.6 quality score

Version information

  • 1.0.0 (latest)
  • 0.0.8
  • 0.0.7
  • 0.0.6
  • 0.0.5
  • 0.0.4
  • 0.0.3
  • 0.0.2
  • 0.0.1
released May 18th 2016
This version is compatible with:
  • RedHat, Amazon, CentOS, Ubuntu

Start using this module

Tags: phantomjs

Documentation

3fs/phantomjs — version 1.0.0 May 18th 2016

puppet-phantomjs

Simple puppet module that installs PhantomJS - headless WebKit scriptable with a Javascript API.

Using

class { '::phantomjs':
    package_version => '1.9.7',
    package_update => true,
    install_dir => '/usr/local/bin',
    source_dir => '/opt',
    timeout => 300
}

The module pulls in curl, bzip2 and libfontconfig1 if you haven't defined those packages yourself. This module depends on puppetlabs/stdlib 4.x module.