pdk

pdk
Module to install the Puppet Development Kit or PDK, created with the pdk... ironically

abuxton

abuxton

14,525 downloads

5,650 latest version

5.0 quality score

Version information

  • 0.2.2 (latest)
  • 0.2.0
  • 0.1.0
  • 0.0.2
released Apr 3rd 2019
This version is compatible with:
  • Puppet Enterprise 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 4.7.0 < 6.0.0
  • RedHat
    ,
    Ubuntu
    ,
    Darwin
    ,
    CentOS
    ,
    OracleLinux
    ,
    RedHat
    ,
    Scientific
    ,
    windows

Start using this module

Documentation

abuxton/pdk — version 0.2.2 Apr 3rd 2019

pdk

Table of Contents

Description

Module to installl the Puppet Development Kit when you are using a Puppetized node as a workstation.

For more information on the PDK, https://docs.puppet.com/pdk/1.0/#getting-started or the list of supported platforms. https://puppet.com/download-puppet-development-kit

Setup

What pdk affects OPTIONAL

installs the Puppet PDK in the default manner

Setup Requirements OPTIONAL

Puppet installed,

Beginning with pdk

Simply

include pdk

The module uses Facter to determine the platform.

Usage

N/A

Reference

Limitations

The PDK has it's own prerequisites for usage and support of Puppet language.

TODO

Provide support for following OS's

  • SLES

Development

Release Notes/Contributors/Etc.