Forge Home

php5

Puppet module to install php5

16,778 downloads

6,378 latest version

3.1 quality score

Version information

  • 0.6.0 (latest)
  • 0.5.4
  • 0.5.2
  • 0.5.1
  • 0.5.0
  • 0.4.6
  • 0.4.5
  • 0.4.3
  • 0.4.2
  • 0.4.1
  • 0.4.0
  • 0.3.2
  • 0.3.1
  • 0.2.1
  • 0.2.0
  • 0.1.8
  • 0.1.7
  • 0.1.6
  • 0.1.5
  • 0.1.4
  • 0.1.3
  • 0.1.2
  • 0.1.1
  • 0.1.0
released Dec 26th 2016
This version is compatible with:
  • Puppet 3.x
  • Ubuntu

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'gajdaw-php5', '0.6.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add gajdaw-php5
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install gajdaw-php5 --version 0.6.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

gajdaw/php5 — version 0.6.0 Dec 26th 2016

Puppet Module

gajdaw/php5

Table of Contents

  1. Overview
  2. Setup
  3. Usage
  4. Limitations

Overview

The module installs php5 using ppa:ondrej/php5 repository.

CAUTION

This module manages in fact both: php5 and apache!

Setup

To install the module run:

sudo puppet install module gajdaw-php5

Usage

You can use the module running the following command:

sudo puppet apply -e 'include php5'

The examples are located in examples/ directory.

Limitations

The module was tested on all the platforms that appear in metadata.json.