scldevtoolset

pdk
Install Software Collections Developer Toolset Module
jmciver

jmciver

jmciver

3,042 downloads

774 latest version

5.0 quality score

Version information

  • 0.2.0 (latest)
  • 0.1.1
released Aug 10th 2020
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x, 2017.2.x, 2016.4.x
  • Puppet >= 4.10.0 < 7.0.0
  • CentOS

Start using this module

Documentation

jmciver/scldevtoolset — version 0.2.0 Aug 10th 2020

Software Collections Developer Toolset

Build Status

Install Software Collections Developer Toolset packages.

Table of Contents

  1. Description
  2. Setup - the basics of getting started with scldevtoolset
  3. Usage - Configuration options
  4. Limitations - OS compatibility, etc.
  5. Development - Guide for contributing to the module
  6. License - Where and how this module can be used

Description

This module will enable the Software Collections repository and install the specified version or versions of the Development Tools package. Versions of the Developer Tools that are not specified are removed. YAML configuration is supported.

Supported Operating Systems

Currently only CentOS 6 and 7 platforms are supported. RedHat Workstation support is currently under development.

6 7 8
CentOS Yes Yes NA
RHEL No No NA

Setup

Beginning with scldevtoolset

The default configuration installs version 9 of the Developer Tools:

include scldevtoolset

Usage

Install version 8 of the Developer Tools:

class { 'scldevtoolset':
  versions => [8]
}

Install versions 7, 8, and 9 of the Developer Tools:

class { 'scldevtoolset':
  versions => [7, 8, 9]
}

Install version 9 of and supporting environment module:

class { 'scldevtoolset':
  versions    => [9],
  use_modules => true,
}

The environment-module system package can installed by setting the install_modules_package parameter to true.

YAML

Install version 8 of the Developer Tools:

scldevtoolset::versions:
  - 8

Install versions 7, 8, and 9 of the Developer Tools:

scldevtoolset::versions:
  - 7
  - 8
  - 9

Install version 9 of and supporting environment module:

scldevtoolset::versions:
  - 9
scldevtoolset::use_modules: true

Limitations

Currently this module only supports CentOS version 6 and 7.

Development

Will add to this later.

License

This module is released under the Apache-2.0 license.