security

Operating system security hardening

John Larson

johnclarson

5,601 downloads

4,236 latest version

1.8 quality score

Version information

  • 0.1.3 (latest)
  • 0.1.2
  • 0.1.1
  • 0.1.0
released Jun 6th 2018

Start using this module

Documentation

johnclarson/security — version 0.1.3 Jun 6th 2018

security

Table of Contents

  1. Overview
  2. Module Description - What the module does and why it is useful
  3. Setup - The basics of getting started with security
  4. Usage - Configuration options and additional functionality
  5. Reference - An under-the-hood peek at what the module is doing and how
  6. Limitations - OS compatibility, etc.
  7. Development - Guide for contributing to the module

Overview

This is a basic operating system security hardening module for basic Nessus scans. Currently, it only works with CentOS 7 but should work with most puppet versions.

Module Description

Very basic right now. Just an init.pp with file, service and augeas rules.

Setup

Requires puppetlabs-inifile

What security affects

This module can affect many core security files and services. Warning It may cause existing applications or functions to fail. Proceed with caution.

Beginning with security

Usage

Reference

Classes: security

Limitations

Only works with CentOS 7 currently.

Development

Feel free to fork this and improve/add to it.