moderninfra

An opioninated module to install rabbitmq, mcollective, sensu, & logstash

Matthew Barr

mbarr

8,743 downloads

8,743 latest version

1.9 quality score

Version information

  • 0.1.0 (latest)
released Jul 8th 2014

Start using this module

Documentation

mbarr/moderninfra — version 0.1.0 Jul 8th 2014

moderninfra

Table of Contents

  1. Overview
  2. Module Description - What the module does and why it is useful
  3. Setup - The basics of getting started with moderninfra
  4. Usage - Configuration options and additional functionality
  5. Reference - An under-the-hood peek at what the module is doing and how
  6. Limitations - OS compatibility, etc.
  7. Development - Guide for contributing to the module

Overview

An opioninated module to install rabbitmq, mcollective, sensu, & logstash. It's a module from a talk atPuppetCamp NYC 2014 talk: Building a Modern Infrastructure in 45 min.

The templates and other ancillary code, including the Puppetfile for librarian-puppet, are at https://github.com/matthewbarr/build-modern-infra

Module Description

Sorry, this will be updated, but the module needed to uploaded to the forge before the talk!

Setup

What moderninfra affects

Setup Requirements OPTIONAL

Beginning with moderninfra

Usage

Reference

Limitations

Should be workable on Ubuntu, 12.04 & 14.04. There are some issues w/ Logtash on 14.04, as of 7/8/14. The kernel fix is in proposed, and should be fixed for real soon.

Development

Send a PR!