glare

Puppet module for OpenStack Glare

openstack

openstack

8,610 downloads

267 latest version

5.0 quality score

Version information

  • 7.1.0 (latest)
  • 7.0.0
  • 6.4.0
  • 6.3.0
  • 6.2.0
  • 6.1.0
  • 5.3.0
  • 5.2.1
  • 5.1.0
  • 5.0.0
  • 4.4.0
  • 4.2.0
  • 4.1.0
  • 4.0.0
  • 3.4.0
  • 3.2.0
released Jan 18th 2021
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x
  • Puppet >= 6.0.0 < 7.0.0
  • RedHat
    ,
    CentOS
    ,
    Ubuntu

Start using this module

Documentation

openstack/glare — version 7.1.0 Jan 18th 2021

Team and repository tags

Team and repository tags

glare

Table of Contents

  1. Overview - What is the glare module?
  2. Module Description - What does the module do?
  3. Setup - The basics of getting started with glare
  4. Implementation - An under-the-hood peek at what the module is doing
  5. Limitations - OS compatibility, etc.
  6. Development - Guide for contributing to the module
  7. Release Notes - Release notes for the project
  8. Contributors - Those with commits
  9. Repository - The project source code repository

Overview

The glare module is a part of OpenStack, an effort by the OpenStack infrastructure team to provide continuous integration testing and code review for OpenStack and OpenStack community projects not part of the core software. The module its self is used to flexibly configure and manage the glare service for OpenStack.

Module Description

The glare module is a thorough attempt to make Puppet capable of managing the entirety of glare. This includes manifests to provision region specific endpoint and database connections. Types are shipped as part of the glare module to assist in manipulation of configuration files.

Setup

What the glare module affects

  • Glare, the glare service for OpenStack.

Installing glare

glare is not currently in Puppet Forge, but is anticipated to be added soon.  Once that happens, you'll be able to install glare with:
puppet module install openstack/glare

Beginning with glare

To utilize the glare module's functionality you will need to declare multiple resources.

Implementation

glare

glare is a combination of Puppet manifest and ruby code to delivery configuration and extra functionality through types and providers.

Limitations

  • All the glare types use the CLI tools and so need to be ran on the glare node.

Development

Developer documentation for the entire puppet-openstack project.

Release Notes

Contributors

Repository