earlyoom

Installs and configure earlyoom
Vox Pupuli

Vox Pupuli

puppet

1,709 downloads

640 latest version

5.0 quality score

Version information

  • 1.1.0 (latest)
  • 1.0.0
released Sep 14th 2020
This version is compatible with:
  • Puppet Enterprise 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x
  • Puppet >= 5.5.8 < 7.0.0
  • CentOS
    ,
    RedHat
    ,
    Debian
    ,
    Ubuntu

Start using this module

Tags: earlyoom, oom

Documentation

puppet/earlyoom — version 1.1.0 Sep 14th 2020

Puppet Module for EarlyOOM

Build Status Code Coverage Puppet Forge Puppet Forge - downloads Puppet Forge - endorsement Puppet Forge - scores

This puppet module:

  • Installs earlyoom package
  • Configures /etc/default/earlyoom
  • Controls the service earlyoom

The Early OOM Daemon checks the amount of available memory and free swap up to 10 times a second (less often if there is a lot of free memory). By default if both are below 10%, it will kill the largest process (highest oom_score). The percentage value is configurable via command line arguments.

github.com/rfjakob/earlyoom

Examples

class{'earlyoom':}
class{'earlyoom':
  interval        => 120,
  ignore_positive => true,
  notify_send     => true,
  debug           => true,
  priority        => true,
  prefer          => '(^|/)(init|X|sshd|firefox)$',
  avoid           => '(^|/)(cupsd|xrootd)$',
  notify_command  => '/bin/echo ${UID}',
  memory_percent  => 20,
  swap_percent    => [10,4]
  memory_size     => 20000,
  swap_size       => [30000,60000],
  dryrun          => false,
}

Documentation

See REFERENCE.md

License

Apache-2.0

Copyright

Steve Traylen, steve.traylen@cern.ch, CERN, 2020.

Contact

Steve Traylen steve.traylen@cern.ch

Support

Please log tickets and issues at our Projects site