Forge Home

apache

Generic APACHE with PHP module that supports many platforms

6,141 downloads

6,124 latest version

2.0 quality score

Version information

  • 2.2.15 (deleted)
  • 2.2.1 (latest)
released Nov 28th 2017
This version is compatible with:
  • Puppet Enterprise >= 3.3.0
  • Puppet >= 3.3.0 < 5.0.0
  • , , , , , , OpenSUSE

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'roshan-apache', '2.2.1'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add roshan-apache
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install roshan-apache --version 2.2.1

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

roshan/apache — version 2.2.1 Nov 28th 2017

roshan/apache Puppet Module

roshan/apache is a Puppet module for managing Apache with a strong focus on php-fpm. The module aims to use sane defaults for the supported architectures. We strive to support all recent versions of Debian, Ubuntu, RedHat/CentOS, openSUSE/SLES and FreeBSD. Managing Apache with mod_php is supported.

roshan/php Puppet Module

roshan/php is a Puppet module for managing PHP with a strong focus on php-fpm. The module aims to use sane defaults for the supported architectures. We strive to support all recent versions of Debian, Ubuntu, RedHat/CentOS, openSUSE/SLES and FreeBSD. Managing Apache with mod_php is supported.

This originally was a fork of jippi/puppet-php (nodes-php on Puppet Forge) but has since been rewritten in large parts.

Usage

Quickest way to get started is simply include'ing the apache class.

include 'apache'

Usage

Quickest way to get started is simply include'ing the php class.

include '::php'