Version information
This version is compatible with:
Start using this module
Add this module to your Puppetfile:
mod 'shawnferry-solaris_providers', '2.0.1'
Learn more about managing modules with a PuppetfileDocumentation
solaris_providers Module for Puppet
Table of Contents
- Overview
- Module Description - What the module does and why it is useful
- Setup - The basics of getting started with solaris_providers
- Usage - Configuration options and additional functionality
- Limitations - OS compatibility, etc.
- Development - Guide for contributing to the module
Overview
The Oracle Solaris Providers module includes Solaris-specific implementations of types and providers. These include some common features as well as features found exclusively on Oracle Solaris.
This is a direct fork of the presumably abandonded provider puboished by Oracle. Beyond simple naming and metadata changes this is identical to the provider expected to ship natively with Solaris 11.4/11.next
Module Resource Type Reference
The Oracle Solaris Providers module currently enables configuration of the following:
- Boot Environments via beadm
- Naming Services via svccfg, svcprop
- Image Pacakging System (IPS) configuration via pkg
- Solaris Integrated Load Balancer (ILB) via ilbadm
- Solaris Elastic Virtual Switch (EVS) via evsadm
- Service Management Facility (SMF) Properties via svccfg, svcprop
- IP Interface Configuration via ipadm
- Datalink Management via dladm
- ZFS ACLs and file Attributes via chmod
Oracle Solaris Providers override the core Puppet providers for:
- Zones via zoneadm, zonecfg
See documentation index for details
Setup
For Solaris 11.x puppet module install oracle-solaris_providers
For Solaris 12.x pkg install puppet
No additional setup or configuration is required.
Beginning with solaris_providers
Common activities include modifying service properties
Two ways to change the domain configuration:
-
Via svccfg
# Service is provided by Core Puppet # Make sure dns/client:default is running # Required for notification of property change service { 'svc:/network/dns/client:default': ensure => 'running' } # Set domain to oracle.lab, dns/client:default must be refreshed to # write the config to /etc/resolv.conf svccfg { 'svc:/network/dns/client:default/:properties/config/domain': ensure => 'present', type => 'astring', value => 'oracle.lab', notify => Service['svc:/network/dns/client:default']; }
-
Via the DNS provider
# Set the domain to oracle.lab dns { 'current': domain => 'oracle.lab' }
Set the server for puppet/agent
# enable puppet:agent
service { 'svc:/application/puppet:agent':
ensure => 'running'
}
# configure puppet:agent, refresh the service to write puppet.conf
svccfg { 'svc:/application/puppet:agent/:properties/config/server':
ensure => 'present',
type => 'astring',
value => 'puppet',
notify => Service['svc:/application/puppet:agent'],
}
Usage
See links to extracted documents listed above.
Limitations
These modules were created for use on Oracle Solaris 11 and 12.
Development
Contributors should issue pull requests via Github see contributing and testing.
Notes
Package installation is via Puppet Core package provider
Solaris providers are shipped with Solaris in the oracle-solaris_providers IPS package and installed automatically with puppet. Use of the module from the Puppet Forge is possible. However, it will result in errors from pkg verify as the IPS oracle-solaris_providers package cannot be removed.
2.0.1
Bugs Fixes and Enhancements
- 23593309 rspec tests need to be written for solaris_providers link_properties
- 25416733 puppet nsswitch does not accept user as a printer database
- 25416766 puppet module regressions 2.0.0
- 25438739 puppet zone provider does not understand 'unavailable' state
2.0.0
Puppet 4 related changes and Bug Fixes
Incompatible Changes:
- NIS provider securenets argument changes from an Array of components allowing
a single entry to an Array of string entries.
- Previous versions indicated securenets must be a Hash in error messages.
- Incorrect Format did not allow multiple
'host'
definitions
:securenets => {'host' => '1.1.1.1'}
- Old Correct Format allowed one entry
:securenets => ['host','1.1.1.1']
- New Format
:securenets => ['1.1.1.1'] :securenets => ['1.1.1.1','2.2.2.2/255.255.255.0']
- Allowed Format
:securenets => ['host/1.1.1.1'] :securenets => ['1.1.1.1/host','2.2.2.2/255.255.255.0']
- link_aggregation
- now strictly checks option combinations which previously failed during catalog application.
- i.e. temporary interfaces cannot be enable true/false static interfaces do not accept seconds as an argument Note: dhcp is a temporary interface
- resources are considered invalid if they do not define
:lower_links
- interface_properties
- no longer supports the parameter
interface
instead usesname
. This change should be transparent.
- no longer supports the parameter
- address_properties
- no longer supports the parameter
address
instead usesname
. This change should be transparent.
- no longer supports the parameter
- protocol_properties
- no longer supports the parameter
protocol
instead usesname
. This change should be transparent.
- no longer supports the parameter
- LDAP, DNS, and NIS
- Names for these resources must be the string
current
other names are unable to be identified via puppet resource and will not appear to be in sync.
- Names for these resources must be the string
- svccfg
- FMRI arguments
fmri
andprop_fmri
must now be well formed.svc:/system/system-log:rsyslog
vssystem-log:rsyslog
orsystem/system-log:rsyslog
- FMRI arguments
Impacting Changes
- interface_properties
interface
has been renamedname
.name
should be defined as an ip interfacenet0
- properties should be defined as a complex hash of
{ proto => { prop => value }}
- Old style interface (name) definitions
net0/ipv4
continue to work
- svccfg
- resource names should be provided as the fully qualified fmri of the property svc:/[:]/:properties/
- the non-standard type array must be used with string type properties astring, ustring, and opaque when they are being used as a list argument. NOTE When used as a native string type the array will be joined into a single string and the resource will not be idempotent.
- svccfg is only idempotent when any of the following are true
- The property name is fully qualified.
title_patterns
are used to extract details from fully qualified names.
- The property name is fully qualified.
svccfg { 'svc:/system/system-log:rsyslog/:properties/config/log_from_remote': ensure => 'present', type => 'boolean', value => 'false', }
prop_fmri
matches the fully qualified property name
svccfg { 'foo': prop_fmri => 'svc:/system/system-log:rsyslog/:properties/config/log_from_remote', ensure => 'present', type => 'boolean', value => 'false', }
fmri
andproperty
are specified exactly as found in smf
svccfg { 'foo': fmri => 'svc:/system/system-log:rsyslog', property => 'config/log_from_remote', ensure => 'present', type => 'boolean', value => 'false', }
- boot_environments
- Puppet will now fail if a non-existent boot environment is provided as the argument for clone_be
- zpool is ignored if clone_be is provided
- The new read only/ignored property running has been added to allow puppet resource boot_environment output to indicate both the activate and running BE.
Bugs Fixes and Enhancements:
- 19429313 address_object type should support vrrp addresses
- 19888183 publisher provider is applied on each puppet run
- 22072780 pkg_publisher provider applies 'searchfirst' every time
- 22125767 nsswitch provider missing ipnodes, protocols
- 22126108 add process scheduler administration provider
- 23593229 rspec tests need to be written for solaris_providers boot_environment
- 23593308 rspec tests need to be written for solaris_providers ipmp_interface
- 23593316 rspec tests need to be written for solaris_providers protocol_properties
- 23593319 rspec tests need to be written for solaris_providers vnic
- 23593225 rspec tests need to be written for solaris_providers etherstub
- 23593310 puppet module rspec tests and validation for nsswitch
- 24696809 Puppet link aggregation modules cascading errors
- 24836004 '-' is valid in pkg mediator implementation
- 24836209 nis provider needs to support multiple securenets entries
- 25022632 puppet ipmp_interface type should not validate interface existence
- 25022632 puppet ipmp_interface type should not validate interface existence
- 25022714 Puppet SMF service should not refresh on every apply operation
- 25071681 puppet dns resource generates invalid manifest
- 25071686 puppet resource ldap; Error: Could not run: No ability to determine if ldap...
- 25071690 puppet resource nis; Error: Could not run: No ability to determine if nis exists
- 25106150 Nis provider is not idempotent
- 25106155 DNS provider is not idempotent
- 25163776 puppet link_aggregation misunderstands 'address' -u output
- 25163791 puppet link_aggregation should use resource values instead of property_hash
- 25163815 puppet address_object errors and validations could be better
- 25163840 puppet puppet::property::list types conflict with internally generated arrays
- 25163864 puppet link_aggregation type specs need to be written
- 25177901 puppet beadm should not use both -e and -p
- 25178928 puppet link_aggregation should try to copy existing values on change of mode
- 25179040 puppet link_aggregation should delete with -t for temporary
- 25191982 puppet type 'dns' is not able to set 'options' property in resolv.conf
- 25192742 puppet svccfg shouldn't try to update properties for a non-existent fmri
- 25196056 puppet interface and address _properties namevars are problematic
- 25211935 puppet link_aggregation needs to permanently delete before modifying temporary
- 25217063 puppet protocol_properties is not idempotent
- 25218036 puppet resource svccfg emits a warning for every property
- 25218053 puppet svccfg prefetch should match individually specified parameters
- 25218208 puppet svccfg should enforce well-formedness in fmri parameters
- 25224661 puppet resource address_properties shouldn't output read-only properties
- 25224777 puppet address_properties should not reset unchanged properties
- 25225039 puppet svccfg should not declare a property absent if it does not match desired
- 25306835 puppet boot_environment needs to understand the new snapshot format
- 25306877 puppet svccfg should check for pg and allow nested property groups
- 25306904 puppet dns,nis,ldap,protocol_properties prefetch fails after input auto munge
- 25348321 puppet boot_environment needs to validate all properties and parameters
- 25354751 puppet vnic provider needs to support / and - as valid vnic name characters
1.2.2
This release unifies the source for the oracle-solaris_providers IPS package.
Puppet Forge Packages will not be built from this branch until
spec testing has been completed.
This release changes embedded licenses from CDDL to Apache 2.0
Bugs Fixed:
- 21626572 svccfg provider does not support multi-valued properties
- 22259529 pkg_mediator fails on previously set implementation parameter
- 23332786 Solaris NIS provider needs to validate securenets parameter
- 23338926 Puppetx / PuppetX namespace change
- 23484766 describe output for interface_properties should reference ipadm(8)
- 23586971 Puppet link aggregation code needs to be updated based on the dladm command chan
- 23593312 rspec tests need to be written for solaris_providers link_aggregation
- 23641391 Do not enable permanent addresses for ipadm
1.2.1
This release unifies the source for the oracle-solaris_providers IPS package. Puppet Forge Packages will not be built from this branch until spec testing has been completed.
Bugs Fixed:
- 21626572 svccfg provider does not support multi-valued properties
- 22259529 pkg_mediator fails on previously set implementation parameter
- 23332786 Solaris NIS provider needs to validate securenets parameter
- 23338926 Puppetx / PuppetX namespace change
- 23484766 describe output for interface_properties should reference ipadm(8)
1.0.2
Version as once released on the Forge
Dependencies
Apache License Version 2.0, January 2004 http://www.apache.org/licenses/ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION 1. Definitions. "License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1 through 9 of this document. "Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the License. "Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or are under common control with that entity. For the purposes of this definition, "control" means (i) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of such entity. "You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License. "Source" form shall mean the preferred form for making modifications, including but not limited to software source code, documentation source, and configuration files. "Object" form shall mean any form resulting from mechanical transformation or translation of a Source form, including but not limited to compiled object code, generated documentation, and conversions to other media types. "Work" shall mean the work of authorship, whether in Source or Object form, made available under the License, as indicated by a copyright notice that is included in or attached to the work (an example is provided in the Appendix below). "Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work and for which the editorial revisions, annotations, elaborations, or other modifications represent, as a whole, an original work of authorship. For the purposes of this License, Derivative Works shall not include works that remain separable from, or merely link (or bind by name) to the interfaces of, the Work and Derivative Works thereof. "Contribution" shall mean any work of authorship, including the original version of the Work and any modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this definition, "submitted" means any form of electronic, verbal, or written communication sent to the Licensor or its representatives, including but not limited to communication on electronic mailing lists, source code control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding communication that is conspicuously marked or otherwise designated in writing by the copyright owner as "Not a Contribution." "Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has been received by Licensor and subsequently incorporated within the Work. 2. Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or Object form. 3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license applies only to those patent claims licensable by such Contributor that are necessarily infringed by their Contribution(s) alone or by combination of their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work constitutes direct or contributory patent infringement, then any patent licenses granted to You under this License for that Work shall terminate as of the date such litigation is filed. 4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions: (a) You must give any other recipients of the Work or Derivative Works a copy of this License; and (b) You must cause any modified files to carry prominent notices stating that You changed the files; and (c) You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and (d) If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as modifying the License. You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License. 5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of this License, without any additional terms or conditions. Notwithstanding the above, nothing herein shall supersede or modify the terms of any separate license agreement you may have executed with Licensor regarding such Contributions. 6. Trademarks. This License does not grant permission to use the trade names, trademarks, service marks, or product names of the Licensor, except as required for reasonable and customary use in describing the origin of the Work and reproducing the content of the NOTICE file. 7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or redistributing the Work and assume any risks associated with Your exercise of permissions under this License. 8. Limitation of Liability. In no event and under no legal theory, whether in tort (including negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including any direct, indirect, special, incidental, or consequential damages of any character arising as a result of this License or out of the use or inability to use the Work (including but not limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial damages or losses), even if such Contributor has been advised of the possibility of such damages. 9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or rights consistent with this License. However, in accepting such obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any such warranty or additional liability. END OF TERMS AND CONDITIONS APPENDIX: How to apply the Apache License to your work. To apply the Apache License to your work, attach the following boilerplate notice, with the fields enclosed by brackets "{}" replaced with your own identifying information. (Don't include the brackets!) The text should be enclosed in the appropriate comment syntax for the file format. We also recommend that a file or class name and description of purpose be included on the same "printed page" as the copyright notice for easier identification within third-party archives. Copyright {yyyy} {name of copyright owner} Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.