Forge Home

simp_elasticsearch

SIMP module for integrating elastic/puppet-elasticsearch

9,075 downloads

4,692 latest version

5.0 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 5.0.5 (latest)
  • 5.0.1
  • 5.0.0
  • 4.1.0
  • 3.0.3
  • 3.0.2
released Nov 27th 2018
This version is compatible with:
  • Puppet Enterprise 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 4.7.0 < 6.0.0
  • , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'simp-simp_elasticsearch', '5.0.5'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add simp-simp_elasticsearch
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install simp-simp_elasticsearch --version 5.0.5

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

simp/simp_elasticsearch — version 5.0.5 Nov 27th 2018
  • Update badges and contribution guide URL in README.rst
  • Updated $app_pki_external_source to accept any string. This matches the functionality of pki::copy.
  • Add missing simp/pam dependency
  • Cleanup unneeded fixtures and update CI assets
  • Update for Puppet 5 and OEL support
  • Update upperbound on puppetlabs/java version to < 3.0.0
  • Test with elastic/elasticsearch 5.5.0
  • Update custom Puppet 3 functions to namespaced, Puppet 4 functions
  • Update puppet requirement and remove OBE pe requirement in metadata.json
  • Update to work with Elasticsearch 5.3
  • All hiera() lookups changed to lookup() or simplib::lookup()
  • Updated pki scheme
  • Application certs now managed in /etc/pki/simp_apps/simp_elasticsearch/x509
  • Cleaned up the manage_httpd logic
  • Removed pupmod-simp-sysctl in favor of augeas-sysctl
  • Updated dependencies for upper bound compatibilities
  • Fixed RPM dependencies
  • Minor cleanup
  • Updated iptables dependency version
  • Updated to use the version of 'simp_apache' that does not conflict with 'puppetlabs/apache'.
  • Changed default data directory to /var
  • Updated Readme with SSL verify note
  • Fixed malformed dependency in metadata.json.
  • Removed the hook to the es2unix packages since they have been replaced by the '_cat' endpoint.
  • Name change to pupmod-simp-simp_elasticsearch as a new integration module.
  • Updated to work with the latest elasticsearch module.
  • migration to simplib and simpcat (lib/ only)
  • Updated to move into the new default 'simp' environment.
  • Correct the permissions on the ES templates directory.
  • Removed our pre-set defaults for the ES tuning. Real world testing indicates that the pre-built defaults perform better.
  • Updated the elasticsearch Apache template in accordance with the latest Apache upgrades.
  • CVE-2014-3566: Updated protocols to mitigate POODLE.
  • Updated to supporrt elasticsearch 1.3, which requires Java 1.7.
  • Added support for installing the es2unix utilities.
  • Updated to use /var/elasticsearch for SIMP>=5
  • Coverted Apache cipher set to array and updated the elasticsearch template.
  • Made things more Hiera friendly.
  • Updated the global ldap* calls to use hiera settings.
  • Removed the es_mem option and added the service_settings hash in its place to allow for maximum flexibility.
  • Moved the insanely large default hashes over to elasticsearch::simp::default and updated the documentation accordingly.
  • Update to fix some typos related to installing java.
  • Updated template to reference instance variables with @
  • Require puppet 3.X and puppet-server 3.X because of an upgrade to use hiera instead of extdata.