simp_logstash

partner
SIMP module for integrating elastic/puppet-logstash

SIMP

simp

7,800 downloads

3,710 latest version

5.0 quality score

Version information

  • 5.0.2 (latest)
  • 5.0.1
  • 5.0.0
  • 4.0.0
  • 2.0.0
released Nov 27th 2018
This version is compatible with:
  • Puppet Enterprise 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 4.7.0 < 6.0.0
  • CentOS
    ,
    RedHat
    ,
    OracleLinux

Start using this module

Tags: simp, logstash

Documentation

simp/simp_logstash — version 5.0.2 Nov 27th 2018
  • Update contribution guide URL in README.rst
  • Updated $app_pki_external_source to accept any string. This matches the functionality of pki::copy.
  • Update systemd fixtures and CI assets
  • Add support for Puppet5 and OEL
  • Update upperbound on puppetlabs/java version to < 3.0.0
  • Adjust string match in acceptance test
  • Updated to LogStash 5.X and Elasticsearch 5.X
  • Fixed type bug in simp_logstash::output::elasticsearch::action.
  • Fixed enum typo in enum for simp_logstash::output::elasticsearch::script_type
  • Fixed puppet strings problems.
  • Confine puppet version in metadata.json
  • Removed pupmod-simp-sysctl in favor of augeas-sysctl
  • Update major version release for SIMP 6
  • Removed stunnel and replaced it with TCP TLS input
  • Added TLS enabled JSON input
  • Updated tests
  • Minor updates
  • Updated iptables dependency version
  • Updated and enabled auditd logstash filters
  • Updated spec and acceptance tests
  • Updated filters to make searching and visualization easier.
  • Updated grok syntax.
  • First cut after being split off from the original simp-logstash module.
  • Provides a much cleaner abstraction between this and the upstream Logstash material from Elastic.